• Быстрый переход
  • Рубрики
  • Свежие записи
  • Метки
  • Архивы
  • Реклама 1
  • Реклама 2
  • Рейтинг@Mail.ru

    Добро пожаловать! Ваш IP-адрес: ec2-23-20-166-68.compute-1.amazonaws.com

    2011 Март

    Смена названия операционной системы из Windows 7 Максимальная на Ultimate

    Открываете с помощью Restorator или PE Explorer файл C:\Windows\Branding\Basebrd\ru-RU\basebrd.dll.mui и правите в нем название операционной системы из Максимальная на Ultimate. Также можно скопировать файл basebrd.dll.mui из папки C:\Windows\Branding\Basebrd\en-US\ в папку C:\Windows\Branding\Basebrd\ru-RU\ если данной папки нет, то файлы можно скачать тут: для x86, для x64

    Защищаемся от почтового спама!

    Защита от почтового спама!
    Для этого нам понадобиться добавить некоторые строки на main.cf  и создать пару файлов!
    Для этого откроем файл для добавления /etc/postfix/main.cf:

    # H/B Checks
    header_checks = regexp:/etc/postfix/maps/header_checks
    mime_header_checks = regexp:/etc/postfix/maps/mime_header_checks
    body_checks = regexp:/etc/postfix/maps/body_checks

    Итак создаем директорию maps и файлик под названием body_checks

    # mkdir /etc/postfix/maps
    # touch /etc/postfix/maps/body_checks


    После чего вносим записи в файл:

    # This will reject emails where any line contains eight or more script/comment tags.
    #/(]*>).*){8}/ REJECT Your email contained a lot of script tags. Please
    # correct this (try setting your mail program to use plain text) and resend your message.
    # This will reject emails with script/comment tags that are in the middle of a word.
    #/^.*[a-z][a-z]/ REJECT Your email contained wrongly placed script tags.
    # Please correct this (try setting your mail program to use plain text) and resend your message.
    # This will reject some variants of Sobig viruses
    /^RSLxwtYBDB6FCv8ybBcS0zp9VU5of3K4BXuwyehTM0RI9IrSjVuwP94xfn0wgOjouKWzGXHVk3qg$/ REJECT Your email looked like it \
    contained a virus. Please run a virus scanner on your computer and try again.
    /^TVqQAAMAAAAEAAAA\/\/8AALgAAAAAAAAAQAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA$/ REJECT Your email looked like \
    it contained a virus. Please run a virus scanner on your computer and try again.
    Подробнее...

    Настройка маршрутизации между vlan Cisco Catalyst-3560

    Задача: настроить маршрутизацию между сетями разных VLAN.

    Настройка Cisco Catalyst-3560 (L3 switch):

    1)Зададим IP – адрес коммутатору:

    Switch(config)#interface vlan 1
    Switch(config-if)#ip address 192.168.1.1 255.255.255.0
    Switch(config-if)# no shutdown

    2)Создадим vlan-ы:

    Switch(config)#vlan 2
    Switch(config-vlan)#name net2
    Switch(config)#vlan 3
    Switch(config-vlan)#name net3

    3)Создадим vlan – интерфейсы:

    Switch(config)#interface vlan 2
    Switch(config-if)#ip address 192.168.2.1 255.255.255.0
    Switch(config)#interface vlan 3
    Switch(config-if)#ip address 192.168.3.1 255.255.255.0

    4)Назначим trunk порты (подключение коммутатор-коммутатор):

    Switch(config)#finterface fastEthernet 0/1
    Switch(config-if)#switchport trunk encapsulation dot1q

    Подробнее...

    Настройка VTP на коммутаторах Cisco

    Настройка VTP версии 2

    Имя VTP-домена (от 1 до 32 символов):

    sw(config)# vtp domain

    Настройка пароля, который будет использоваться для аутентификации в VTP-домене (от 1 до 32 символов):

    sw(config)# vtp password

    Настройка второй версии протокола VTP:

    sw(config)# vtp v2-mode

    Настройка режима VTP:

    sw(config)# vtp mode

    Настройка VTP версии 3

    Версия 3 VTP доступна:

    * на 2960 с 12.2(52)SE
    * на 3560 с 12.2(55)SE
    * на 3750 с 12.2(52)SE

    Подробнее...

    Описание протокола — VLAN Trunking Protocol (VTP)

    VLAN Trunking Protocol (VTP) — проприетарный протокол компании Cisco Systems, предназначенный для создания, удаления и переименования VLANов на сетевых устройствах. Передавать информацию о том, какой порт находится в каком VLANе, он не может.

    Описание протокола: Версии протокола

    Версия 3 VTP доступна:

    * на 2960 с 12.2(52)SE
    * на 3560 с 12.2(55)SE
    * на 3750 с 12.2(52)SE

    Сообщения VTP

    * Summary advertisements
    * Subset advertisements
    * Advertisement requests
    * VTP Join messages (используются для pruning)

    Режимы работы протокола

    На коммутаторе VTP может работать в трёх режимах:

    * Server (режим по умолчанию):
    Можно создавать, изменять и удалять VLAN из командной строки коммутатора,
    Генерирует объявления VTP и передает объявления от других коммутаторов,
    Может обновлять свою базу данных VLAN при получении информации от других VTP-серверов в домене,
    Сохраняет информацию о настройках VLAN в файле vlan.dat во flash,
    * Client:
    Нельзя создавать, изменять и удалять VLAN из командной строки коммутатора,
    Передает объявления от других коммутаторов,
    Синхронизирует свою базу данных VLAN при получении информации VTP,
    Сохраняет информацию о настройках VLAN только в RAM. Если коммутатор был выключен, то информация о VLAN теряется и должна быть обновлена с помощью обновления от сервера или клиента,
    * Transparent:
    Можно создавать, изменять и удалять VLAN из командной строки коммутатора, но только для локального коммутатора,
    Не генерирует объявления VTP,
    Передает объявления от других коммутаторов,
    Не обновляет свою базу данных VLAN при получении информации по VTP,
    Сохраняет информацию о настройках VLAN в NVRAM,
    Всегда использует configuration revision number 0.

    Подробнее...

    Установка Mikrotik по сети используя утилиту netinstall

    Для установки по сети понадобится утилита для удаленной установки (netinstall) и набор пакетов, скачать можно со страницы загрузки с официального сайта Mikrotik.com

    Распаковываем утилиту netinstall и пакеты обновлений в папку на диске.

    Подробнее...

    CDP – Cisco Discovery Protocol во FreeBSD

    Не давно в интернете нашел прикольную статейку и решил ее выложить!
    CDP – Cisco Discovery Protocol, предназначен этот протокол для упрощения поиска устройств в сети, автоматической отрисовки топологии сети, этот протокол в обязательном порядке поддерживается устройствами Cisco, получить информацию на устройстве можно так:

    show cdp neighbors

    Вывод имеет такой вид:

    Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone Device 
    ID Local Intrfce Holdtme Capability Platform Port 
    ID Traversa Gig 1/0/11 137 S I WS-C3560- Gig 0/1 
    sw-core-3k56e Gig 1/0/3 130 H i386 bge0 
    sw-kyiv-2960 Gig 1/0/5 166 S I WS-C2960- Gig 0/2

    Тут отображены все устройства которые передают информацию о себе по протоколу cdp, и как можно увидеть – предоставляется информация о наименовании устройства, интерфейс куда оно включено, сколько времени прошло с последней посылки информации, тип устройства, платформа и идентификатор порта на удаленном устройстве.
    Как можно увидеть it-admin.org – это сервер под управлением FreeBSD в котором я включил поддержку с помощью порта cdpd.
    Установка его проста, в настройке он не нуждается:

    cd /usr/ports/net-mgmt/cdpd/ make install clean

    Подробнее...