• Быстрый переход
  • Рубрики
  • Свежие записи
  • Метки
  • Архивы
  • Реклама 1
  • Реклама 2
  • Рейтинг@Mail.ru

    Добро пожаловать! Ваш IP-адрес: ec2-23-20-166-68.compute-1.amazonaws.com

    2011 Июнь

    Как защитить микротик от сканирования портов?

    В iptables есть правило
    -A INPUT -i eth1 -p tcp -m tcp --tcp-flags FIN,SYN,ACK SYN -j REJECT --reject-with icmp-port-unreachable
    (eth1 - интерфейс с ip в интернет)
    Я пробовал вкл и вкл его. И с внешнего ip сканером портов проверял на открытые порты комп с IPtables.
    При вкл правиле ни одного открытого порта на компе не обнаруживалось.

    Как подобное правило реализовать в микротик?

    Код
    /ip firewall filter
    add chain=input in-interface=eth1 protocol=tcp tcp-flags=syn action=reject reject-with=icmp-network-unreachable
    add chain=input in-interface=eth1 protocol=tcp tcp-flags=fin,syn,ack action=reject reject-with=icmp-network-unreachable

    но если включен Connection Tracking, то проще - так:

    Код
    /ip firewall filter add chain=input in-interface=eth1 connection-state=new action=reject reject-with=icmp-network-unreachable

    Защита Mikrotik от брутфорса

    Если вы хотите заблокировать доступ после 10-и не правильных попыток в минуту:

    код для /ip firewall filter

    add chain=input protocol=tcp dst-port=21 src-address-list=ftp_blacklist action=drop \
    comment="drop ftp brute forcers"

    add chain=output action=accept protocol=tcp content="530 Login incorrect" dst-limit=1/1m,9,dst-address/1m

    add chain=output action=add-dst-to-address-list protocol=tcp content="530 Login incorrect" \
    address-list=ftp_blacklist address-list-timeout=3h

    Это предотвратит SSH брутфорс на 10 дней после повторяющихся попыток. Измените блокировку по времени в случае необходимости.
    код для /ip firewall filter:

    add chain=input protocol=tcp dst-port=22 src-address-list=ssh_blacklist action=drop \
    comment="drop ssh brute forcers" disabled=no

    add chain=input protocol=tcp dst-port=22 connection-state=new \
    src-address-list=ssh_stage3 action=add-src-to-address-list address-list=ssh_blacklist \
    address-list-timeout=10d comment="" disabled=no

    add chain=input protocol=tcp dst-port=22 connection-state=new \
    src-address-list=ssh_stage2 action=add-src-to-address-list address-list=ssh_stage3 \
    address-list-timeout=1m comment="" disabled=no

    add chain=input protocol=tcp dst-port=22 connection-state=new src-address-list=ssh_stage1 \
    action=add-src-to-address-list address-list=ssh_stage2 address-list-timeout=1m comment="" disabled=no

    add chain=input protocol=tcp dst-port=22 connection-state=new action=add-src-to-address-list \
    address-list=ssh_stage1 address-list-timeout=1m comment="" disabled=no

    Перемещение системных папок и изменение их путей

    Перенос системных папок лучше сделать сразу после установки Windows, до установки программ и драйверов, т.к. при установке драйверов и в особенности программ будут создаваться каталоги и ярлыки в эти самые системные папки. Если Вы используете для хранения файлов системные папки, то перенос системных папок пользователя на не системный диск, поможет Вам сохранить свои файлы. В случае сбоя Windows, при её переустановке заданные по умолчанию системные папки будут затерты полностью, со всеми находящимися в них файлами. Но если Вы зададите свои пути к системным папкам, то всё их содержимое останется целым.

    Раньше в предыдущих версиях Windows, чтобы переместить какую-либо системную папку или изменить её путь, Вам надо было править нужное Вам значение в одной из следующих веток реестра:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    Компания Microsoft понимая, что многие пользователи могут захотеть переместить свои системные папки, упростила пользователям эту задачу, избавив их от надобности редактировать реестр. Для перемещения системных папок и изменения их путей проделайте следующее:

    Подробнее...

    Удаление символов ^M с помощью sed

    Все время забываю синтаксис sed для удаления символов переноса строк ^M формата DOS, которые можно встретить в текстовых файлах после редактированиях в windows редакторах.

    Они меня почему-то ужасно раздражают и я вечно стремлюсь от них избавиться. Поэтому решил кинуть в блог небольшую памятку, чтобы была всегда под рукой.

    Символы переноса строк ^M, которые следует удалить, можно получить в консоли набрав комбинацию на клавиатуре:  сначала control + V и следом за этим control + M

    Вот так выглядят переносы ^M в текстовом редакторе mcedit:


    Синтаксис sed для удаления ^M следующий
    sed 's/'"$(printf '\015')"'$//g' имя_файла

    Также можно еще так:

    find . -type f | xargs -n1 sed -i » -e ‘s/^M$//’

    или так

    find . -type f | xargs -n1 sed -i -e ‘s/^M$//’

    тогда создадутся копии исходных файлов с -е в конце имени ^M в bash можно набрать нажав CTRL+V+M

    Ну и самый простой вариант это установка с портов пакета:

    /usr/ports/converters/dosunix

    Автор admin, 5 июня 2011 | OS FreeBSD, Новости | 1 коммент.
    Метки: , , , , , , ,