• Быстрый переход
  • Рубрики
  • Свежие записи
  • Метки
  • Архивы
  • Реклама 1
  • Реклама 2
  • Рейтинг@Mail.ru

    Q-in-Q настройка в Cisco Catalyst 3750


    Q-in-Q, так же это называют dot1q tunneling, это система двойного тегирования вланов. То есть, допустим у нас есть канал на некую тех площадку, на которой подключены клиенты, клиенты должны быть изолированы друг от друга с помощью vlan, но транспорт не позволяет обеспечить нужное количество вланов на каждого клиента, а владельцы транспорта дают один влан и как говорится крутись как хочешь. Вот для таких случаев замечательно подходит dot1q туннелирование, когда внутрь одного влана на входе упаковываются вланы, а на выходе транспорта распаковываются. Остается добавить, что не все виды коммутаторов поддерживают Q-in-Q, среди коммутаторов Cisco поддерживают Q-in-Q 35хх, 37xx, 45xx. Среди продуктов D-Link поддерживает Des-3825, тут Q-in-Q называется Double Vlan. И все коммутаторы производства ExtremeNetworks, они называют эту технологию vMan.

    Схема коммутации для создания Q-in-Q будет выглядеть так:

    На сервере (он является маршрутизатором для клиентов) терминируются все клиентские вланы(11,12, 13, 14, 15), порт GigabitEthernet 1/0/1 Switch 1, находится в режиме транка, и имеет такую конфигурацию:

    interface GigabitEthernet1/0/1
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 11-15
     switchport mode trunk
     speed nonegotiate
     no cdp enable
     spanning-tree bpdufilter enable
     spanning-tree bpduguard enable
    !

    Порт GigabitEthernet1/0/2 соединен со Switch 2 порт GigabitEthernet1/0/1, нужно это для того, что бы отдать пакеты в порт который будет заворачивать весь трафик в Q-in-Q и имеет такую конфигурацию:

    interface GigabitEthernet1/0/2
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 11-15
     switchport mode trunk
     speed nonegotiate
     no cdp enable
     spanning-tree bpdufilter enable
     spanning-tree bpduguard enable
    !

    Порт Switch2 GigabitEthernet1/0/1 находится в режиме Q-in-Q, то есть все приходящие пакеты инкапсулирует во влан 10, и для всех устройств находящихся далее по цепочке виден только один влан, в нашем случае влан 10. А конфигурация порта GigabitEthernet1/0/1 на втором свитче будет такая:

    configure terminal
    interface GigabitEthernet1/0/1
    description -== Q-IN-Q ==-
    switchport access vlan 10
    switchport mode dot1q-tunnel
    switchport nonegotiate
    no mdix auto
    no cdp enable
    spanning-tree bpdufilter enable
    spanning-tree bpduguard enable

    Теперь все приходящее на этот порт будет упаковываться внутрь 10-го влана и соответственно выходить через порт GigabitEthernet1/0/28, его настройки будут такие:

    interface GigabitEthernet1/0/28
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 10
     switchport mode trunk
     speed nonegotiate
     no cdp enable
     spanning-tree bpdufilter enable
     spanning-tree bpduguard enable
    !

    Далее идет оборудование компании предоставляющей транспорт до нашей тех площадки, на схеме это все оборудование обозначено как некое облако, о содержимом которого мы ничего не знаем, да и знать нам не надо.
    На удаленной тех площадке наш влан приходит в порт GigabitEthernet1/0/28 Switch3 с конфигурацией идентичной настроенной на Switch 2 порт GigabitEthernet1/0/28.

    interface GigabitEthernet1/0/28
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 10
     switchport mode trunk
     speed nonegotiate
     no cdp enable
     spanning-tree bpdufilter enable
     spanning-tree bpduguard enable
    !

    Трафик приходит на порт GigabitEthernet1/0/28 Switch3 имеющий двойной тег, то есть Q-in-Qшный, теперь его надо распаковать, соответственно порт GigabitEthernet1/0/1 находится в режиме Q-in-Q. Настройки его такие:

    interface GigabitEthernet1/0/1
    description -== Q-IN-Q ==-
    switchport access vlan 10
    switchport mode dot1q-tunnel
    switchport nonegotiate
    no mdix auto
    no cdp enable
    spanning-tree bpdufilter enable
    spanning-tree bpduguard enable

    Остался последний свитч Switch4, в который и включаются все клиенты. Со Switch3 он соединен через порт GigabitEthernet1/0/1 со своей стороны и в GigabitEthernet1/0/1 на Switch3.
    Настройки GigabitEthernet1/0/1 на Switch4 такие:

    interface GigabitEthernet1/0/1
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 11-15
     switchport mode trunk
     speed nonegotiate
     no cdp enable
     spanning-tree bpdufilter enable
     spanning-tree bpduguard enable

    А настройки клиентских портов будут, для первого клиента во влан 11, порт GigabitEthernet1/0/2:

    interface GigabitEthernet1/0/2
     description -== FirstClient ==-
     switchport access vlan 11
     switchport mode access

    второго, подключенного в GigabitEthernet1/0/3, и ходящего по 12 влану, такие:

    interface GigabitEthernet1/0/2
     description -== SecondClient ==-
     switchport access vlan 12
     switchport mode access

    Ну и так далее, идентично для остальных клиентов.
    На этом настройка закончена. Остается только добавить, что схему можно немного упростить физически, построив ее на основе 2 свичей вместо 4-х, для этого необходимо соорудить так называемый Q-in-Q Loop. Об этом я расскажу несколько позднее. И совсем необязательно применять для терминации клиентов равнозначные свитчи, им хватит и свитча попроще, но Q-in-Q придется строить все равно на базе как минимум Cisco Catalyst 35xx. Причем функция Q-in-Q в них не документирована, но работает.

    Автор: admin, 9 апреля 2010
    Рубрики: Cisco Systems, Новости
    Метки: , , , , , ,
    2 комментария к сообщению: “Q-in-Q настройка в Cisco Catalyst 3750”
    1. Azizoro:

      Спасибо, нашел то что искал )

    2. Adderall:

      но Q-in-Q прийдется строить все равно на базе как минимум Cisco Catalyst 35xx. Причем функция Q-in-Q в них не документирована, но работает

    Написать комментарий

    Последние статьи