• Быстрый переход
  • Рубрики
  • Свежие записи
  • Метки
  • Архивы
  • Реклама 1
  • Реклама 2
  • Рейтинг@Mail.ru

    Настраиваем Trunk между свичами Cisco Catalyst и FreeBSD


    И так перед нами стоит задача настроить и соединить два свича и Server на FreeBSD , используя trunk порты, для того, что бы пользователи подключенные к Cisco Catalyst видели IP-адреса FreeBSD и Cisco Catalyst свичи находились во vlan`е управления. Для этого у нас есть два свича Cisco Catalyst 3560G к которым подключены два сегмента сети в разных vlan.

    Схема:

    Switch 1
    Создадим vlan`ы:

    Switch1#configure terminal
    Switch1(config)#vlan 5
    Switch1(config-vlan)#name management
    Switch1(config-vlan)#vlan 10
    Switch1(config-vlan)#name segment_10
    Switch1(config-vlan)#vlan 20
    Switch1(config-vlan)#name segment_20
    Switch1(config-vlan)#exit


    Настроим IP-адрес свича во влане управления:

    Switch1(config)#interface vlan 5
    Switch1(config-if)#ip address 10.0.0.2 255.255.255.248
    Switch1(config-if)#exit


    Поместим пользовательские порты свича в эти vlan`ы:

    Switch1(config)#interface gigabitEthernet 0/2
    Switch1(config-if)#switchport mode access
    Switch1(config-if)#switchport access vlan 10
    Switch1(config-if)#interface gigabitEthernet 0/3
    Switch1(config-if)#switchport mode access
    Switch1(config-if)#switchport access vlan 20

    Настроим trunk на порту смотрящий в сторону Switch2, но разрешим только vlan 5,10 и 20:

    Switch1(config-if)#interface gigabitEthernet 0/1
    Switch1(config-if)#switchport trunk encapsulation dot1q
    Switch1(config-if)#switchport trunk allowed vlan 5,10,20
    Switch1(config-if)#switchport mode trunk

    Будьте внимательны: чтобы в последующем добавлять новые vlan в наш trunk вам необходимо использовать ту же команду, но с ключевым add:

    Switch1(config-if)#switchport trunk allowed vlan add VLAN_ID

    Если вы не будете использовать add, то свич выставит в разрешенные vlan`ы на trunk порту только те что будут вами перечислены и удалит старые значения.

    Switch 2
    Создадим vlan`ы:

    Switch2#configure terminal
    Switch2(config)#vlan 5
    Switch2(config-vlan)#name management
    Switch2(config-vlan)#vlan 10
    Switch2(config-vlan)#name segment_10
    Switch2(config-vlan)#vlan 20
    Switch2(config-vlan)#name segment_20
    Switch2(config-vlan)#exit

    Настроим IP-адрес свича во влане управления:

    Switch2(config)#interface vlan 5
    Switch2(config-if)#ip address 10.0.0.3 255.255.255.248
    Switch2(config-if)#exit

    Поместим пользовательские порты свича в эти vlan`ы:

    Switch2(config)#interface gigabitEthernet 0/11
    Switch2(config-if)#switchport mode access
    Switch2(config-if)#switchport access vlan 20
    Switch2(config-if)#int gi 0/10
    Switch2(config-if)#switchport mode access
    Switch2(config-if)#switchport access vlan 10
    Switch2(config-if)#exit

    Настроим trunk на порту смотрящий в сторону Switch1 и разрешим только vlan 5,10 и 20:

    Switch2(config)#interface gigabitEthernet 0/2
    Switch2(config-if)#switchport trunk encapsulation dot1q
    Switch2(config-if)#switchport trunk allowed vlan 5,10,20
    Switch2(config-if)#switchport mode trunk
    Switch2(config-if)#exit

    Также настроим trunk порт смотрящий в сторону FreeBSD:

    Switch2(config)#interface gigabitEthernet 0/24
    Switch2(config-if)#switchport trunk encapsulation dot1q
    Switch2(config-if)#switchport trunk allowed vlan 5,10,20
    Switch2(config-if)#switchport mode trunk
    Switch2(config-if)#exit

    Настроим сервер FreeBSD

    Создадим vlan управления:

    /sbin/ifconfig vlan5 create
    /sbin/ifconfig vlan5 vlan 5 vlandev em0
    /sbin/ifconfig vlan5 add 10.0.0.1/29
    /sbin/ifconfig vlan5 up


    Создадим vlan 10:

    /sbin/ifconfig vlan10 create
    /sbin/ifconfig vlan10 vlan 10 vlandev em0
    /sbin/ifconfig vlan10 add 192.168.10.1/24
    /sbin/ifconfig vlan10 up

    Создадим vlan 20:

    /sbin/ifconfig vlan20 create
    /sbin/ifconfig vlan20 vlan 20 vlandev em0
    /sbin/ifconfig vlan20 add 192.168.20.1/24
    /sbin/ifconfig vlan20 up

    На этом наша настройка завершина!  Проверяем как работает!

    Автор: admin, 23 февраля 2010
    Рубрики: Cisco Systems, Новости
    Метки: , , , ,

    Написать комментарий

    Последние статьи