• Быстрый переход
  • Рубрики
  • Свежие записи
  • Метки
  • Архивы
  • Реклама 1
  • Реклама 2
  • Рейтинг@Mail.ru

    Настройка маршрутизации между vlan Cisco Catalyst-3560


    Задача: настроить маршрутизацию между сетями разных VLAN.

    Настройка Cisco Catalyst-3560 (L3 switch):

    1)Зададим IP – адрес коммутатору:

    Switch(config)#interface vlan 1
    Switch(config-if)#ip address 192.168.1.1 255.255.255.0
    Switch(config-if)# no shutdown

    2)Создадим vlan-ы:

    Switch(config)#vlan 2
    Switch(config-vlan)#name net2
    Switch(config)#vlan 3
    Switch(config-vlan)#name net3

    3)Создадим vlan – интерфейсы:

    Switch(config)#interface vlan 2
    Switch(config-if)#ip address 192.168.2.1 255.255.255.0
    Switch(config)#interface vlan 3
    Switch(config-if)#ip address 192.168.3.1 255.255.255.0

    4)Назначим trunk порты (подключение коммутатор-коммутатор):

    Switch(config)#finterface fastEthernet 0/1
    Switch(config-if)#switchport trunk encapsulation dot1q

    5)Включим маршрутизацию:

    Switch(config)#ip routing

    6)Настроим DHCP-сервер (имеем 2 vlan-интерфейса, к которым привязаны разные подсети, нужно в каждую подсеть раздать адреса динамически с дефолтным маршрутом)

    6.1)Исключаем адреса шлюзов из доступных адресов для раздачи:

    Switch(config)#ip dhcp excluded-address 192.168.2.1
    Switch(config)#ip dhcp excluded-address 192.168.3.1

    6.2)Затем прописываем пулы адресов для раздачи:

    Switch(config)#ip dhcp pool net2
    Switch(dhcp-config)#network 192.168.2.0 255.255.255.0
    Switch(dhcp-config)#default-router 192.168.2.1
    Switch(config)#ip dhcp pool net3
    Switch(dhcp-config)#network 192.168.3.0 255.255.255.0
    Switch(dhcp-config)#default-router 192.168.3.1

    Настройка Cisco Catalyst-2960 (L2 switch):

    1)Зададим IP – адрес коммутатору:

    Switch(config)#interface vlan 1
    Switch(config-if)#ip address 192.168.1.2 255.255.255.0
    Switch(config-if)# no shutdown

    2)Зададим шлюз коммутатору:

    Switch(config)#ip default-gateway 192.168.1.1

    3)Создадим vlan-ы:

    Switch(config)#vlan 2
    Switch(config-vlan)#name net2
    Switch(config)#vlan 3
    Switch(config-vlan)#name net3

    4)Назначим access порты (подключение ПК-коммутатор):

    Switch(config)#interface range fastEthernet 0/2-10
    Switch(config-if-range)#switchport mode access
    Switch(config-if-range)#switchport access vlan 2
    Switch(config)#interface range fastEthernet 0/11-20
    Switch(config-if-range)#switchport mode access
    Switch(config-if-range)#switchport access vlan 3

    5)Назначим trunk порты (подключение коммутатор-коммутатор):

    Switch(config)#interface fastEthernet 0/1
    Switch(config-if)#switchport mode trunk

    Статья из блога sys-it.ru - Инструкции по администрирование linux и Windows, сети на основе cisco и dlink.

    Автор: admin, 24 марта 2011
    Рубрики: Cisco Systems
    Метки: , , , , , , , , ,
    2 комментария к сообщению: “Настройка маршрутизации между vlan Cisco Catalyst-3560”
    1. Salavat:

      4)Назначим trunk порты…
      #finterface fastEthernet 0/1
      в команде допущен лишний символ — f_interface fa0/1

    2. icclmd.org:

      Если невозможно провести эхо-тест между двумя устройствами в одной и той же VLAN, но на разных коммутаторах, убедитесь в правильности настройки транкинга и совпадении исходной VLAN на обеих сторонах магистрали.

    Написать комментарий

    Последние статьи