• Быстрый переход
  • Рубрики
  • Свежие записи
  • Метки
  • Архивы
  • Реклама 1
  • Реклама 2
  • Рейтинг@Mail.ru

    Первоначальные настройки на Cisco Catalyst 3560G


    И так, для того чтобы нам настроить минимальные настройки на Cisco Catalyst 3560G , необходимо знать , что на любых Cisco по дефолту не имеются ни какие настройки
    т.е. он пуст!!!
    Для того чтобы на начать настраивать понадобиться к свичу подключиться
    в Windows можно использовать Hiper Terminal для подключения к com порту

    1. Первым делом зададим пароль на enable режим

    Switch> enable
    Switch# configure terminal
    Switch(config)# enable password my-secret-password

    2. Установим пароль для входа по telnet

    Switch(config)# line vty 0 15
    Switch(config-line)#password my-telnet-password

    3. Зашифруем пароли, чтобы по sh run они не показывались в открытом виде

    Switch(config)# service password-encryption

    4. Назовем наше устройство, например sw_Core

    Switch(config)# hostname sw_Core

    5. Зададим нашему девайсу IP-адрес

    sw_Core(config)# interface vlan 1
    sw_Core(config-if)# ip address 192.168.1.2 255.255.255.0
    sw_Core(config-if)# exit

    6.  Если вы ошибитесь при наборе чего либо в консоле, то Cisco начнет пытаться это отрезолвить, чем заставляет вас ждать, выключим эту функцию.

    sw_Core(config)# no ip domain-lookup

    7.  Зададим имя домена

    sw_Core(config)# ip domain-name my-domain.org

    8.  Зададим IP-адрес DNS сервера

    sw_Core(config)# ip name-server 192.168.1.15

    9.  Зададим время, если у вас есть доступный NTP сервер

    sw_Core(config)# ntp server 192.168.1.1 version 2 source vlan 1
    sw_Core(config)# ntp clock-period 36029056
    sw_Core(config)# ntp max-associations 1

    где 192.168.1.1 – это IP-адрес NTP сервера
    а используя «добавку» source vlan вы можете четко задать номер vlan с IP которого будет отправляться NTP запрос.

    Если нет NTP сервера, то можно задать время вручную, но для этого придется выйти из режима конфигурирования.

    sw_Core(config)# exit
    sw_Core# clock set 10:00:50 20 Aug 2010

    10.  Сделаем так, чтобы по команде show logging отображалось нормальное время, а не кол-во дней и т.п.

    sw_Core(config)# service timestamps log datetime localtime

    11.  Зададим дефолтовые настройки сразу всем портам на девайсе

    sw_Core(config)# interface range gi 0/1 – 28
    sw_Core(config-if-range)# description not_used
    sw_Core(config-if-range)# shutdown
    sw_Core(config-if-range)# no cdp enable
    sw_Core(config-if-range)# switchport nonegotiate
    sw_Core(config-if-range)# switchport mode access
    sw_Core(config-if-range)# exit

    Рекомендую: все неиспользуемые порты держать выключенными, а ещё лучше создать Vlan (например 999) и все выключенные порты переместить в него:

    sw_Core(config)# vlan 999
    sw_Core(config-vlan)# name unused_ports
    sw_Core(config-vlan)# shutdown
    sw_Core(config-vlan)# exit
    sw_Core(config)# interface range gi 0/1 – 28
    sw_Core(config-if-range)# description not_used
    sw_Core(config-if-range)# shutdown
    sw_Core(config-if-range)# no cdp enable
    sw_Core(config-if-range)# switchport nonegotiate
    sw_Core(config-if-range)# switchport access vlan 999
    sw_Core(config-if-range)# switchport mode access
    sw_Core(config-if-range)# exit

    12.  Зададим gateway по умолчанию (допустим это будет 192.168.1.1, т.к. мы присвоили девайсу IP 192.168.1.2/255.255.255.0)

    sw_Core(config)# ip default-gateway 192.168.1.1

    13.  Если этот свич будет поддерживать маршрутизацию (будет router`ом), то включим функцию маршрутизации 3560G прекрасно справляется с функцией маршрутизации

    sw_Core(config)# ip routing
    sw_Core(config)# ip classless
    sw_Core(config)# ip subnet-zero

    14.  Если вы выполнили пункт 13-й, то снова необходимо задать gateway по умолчанию, но уже другой командой

    sw_Core(config)# ip route 0.0.0.0 0.0.0.0 192.168.1.1

    15.  Настроим access-list для доступа к свичу только с определенных IP-адресов

    sw_Core(config)# ip access-list standard TELNET
    sw_Core(config-std-nacl)# permit 192.168.1.1
    sw_Core(config-std-nacl)# permit 192.168.1.15
    sw_Core(config-std-nacl)# exit

    16.  Применим этот access-list

    sw_Core(config)# line vty 0 15
    sw_Core(config-line)# access-class TELNET in

    17.  Зададим timeout не активности telnet сессии, по истечении указанного времени, если вы в консольке ничего не вводили, то telnet соединение будет автоматически закрываться

    sw_Core(config-line)# exec-timeout 5 0
    sw_Core(config-line)# exit

    18.  Включим SNMP, но только read only (RO) и доступность только с хоста 192.168.1.1

    sw_Core(config)# snmp-server community RO-MY-COMPANY-NAME RO
    sw_Core(config)# snmp-server trap-source Vlan1
    sw_Core(config)# snmp-server source-interface informs Vlan1
    sw_Core(config)# snmp-server location SWITCH-LOCATION
    sw_Core(config)# snmp-server contact my-email@my-domain.ru
    sw_Core(config)# snmp-server host 192.168.1.1 RO-MY-COMPANY-NAME
    sw_Core(config)# exit

    19.  На этом наши настройки завершены ...нам только остается все это сохранить 🙂

    sw_Core# write m

    Автор: admin, 24 января 2010
    Рубрики: Cisco Systems, Новости
    Метки: , ,

    Написать комментарий

    Последние статьи