• Быстрый переход
  • Рубрики
  • Свежие записи
  • Метки
  • Архивы
  • Реклама 1
  • Реклама 2
  • Рейтинг@Mail.ru

    Настройка VRRP на Mikrotik


    "VRRP (Virtual Router Redundancy Protocol) — сетевой протокол, предназначенный для увеличения доступности маршрутизаторов выполняющих роль шлюза по умолчанию. Это достигается путём объединения группы маршрутизаторов в один виртуальный маршрутизатор и назначения им общего IP-адреса, который и будет использоваться как шлюз по умолчанию для компьютеров в сети. "
    Проще говоря VRRP используется для создания отказоустойчивого и производительного "кластера", если проводить аналогию с серверами. Чаще всего резервируется шлюз по умолчанию, настроенный через DHCP на рабочих станциях и серверах.
    Например, есть два маршрутизатора, один основной, а другой резервный. Резервных может быть несколько, переключение происходит по приоритету. Так вот, при падении основного резервный подхватывает все пакеты идущие на шлюз по умолчанию.

    Итак. Два маршрутизатора подключенных к двум внешним каналам, отказоустойчивое решение с основным и резервным маршрутизатором.

    Настройка VRRP на Mikrotik

    Настройка VRRP на Mikrotik

    Сделаем настройки на первом роутере

    [admin@MikroTik] > /ip address add address=192.168.100.1/24 interface=ether1
    [admin@MikroTik] > /interface vrrp add interface=ether1 vrid=100 priority=250
    [admin@MikroTik] > /ip address add address=192.168.100.3/24 interface=vrrp1

    На втором делаем аналогичные настройки, только другой IP-адрес

    [admin@MikroTik] > /ip address add address=192.168.100.2/24 interface=ether1
    [admin@MikroTik] > /interface vrrp add interface=ether1 vrid=100
    [admin@MikroTik] > /ip address add address=192.168.100.3/24 interface=vrrp1

    VRID- идентификатор группы роутеров или идентификатор виртуального роутера.
    priority- роутер с большим приоритетом будет выбран основным(Master), а с меньшим резервным(Slave, backup)
    По умолчанию приоритет 100, поэтому на втором роутере его можно не менять.

    Также пример используя GUI winbox для R2
    Добавляем IP-адрес

    Добавление IP на Микроте

    Добавление IP на Микроте

    Создаем VRRP-интерфейс с заданными атрибутами.

    Создаем VRRP-интерфейс с заданными атрибутами.

    Создаем VRRP-интерфейс с заданными атрибутами.

    Создаем VRRP-интерфейс с заданными атрибутами.

    Создаем VRRP-интерфейс с заданными атрибутами.

    Добавляем виртуальный IP-адрес на интерфейсе vrrp

    Добавляем виртуальный IP-адрес на интерфейсе vrrp

    Добавляем виртуальный IP-адрес на интерфейсе vrrp

    Проверить можно уже когда будет создан VRRP-интерфейс на обоих роутерах в окне Interfaces.
    На основном роутере будет RM router master, а на резервном B.

    vrrp-rez

    Также проверяем через командную строку:
    R1
    /interface vrrp print
    Flags: X - disabled, I - invalid, R - running, M - master, B - backup
    0 RM name="vrrp1" mtu=1500 mac-address=00:00:5E:00:01:64 arp=enabled interface=ether1 vrid=100 priority=250
    interval=1 preemption-mode=yes authentication=none password="" on-backup="" on-master=""

    R2
    /interface vrrp print
    Flags: X - disabled, I - invalid, R - running, M - master, B - backup
    0 B name="vrrp1" mtu=1500 mac-address=00:00:5E:00:01:64 arp=enabled
    interface=ether1 vrid=100 priority=100 interval=1 preemption-mode=yes
    authentication=none password="" on-backup="" on-master=""

    Как видно и MAC-адрес у них один, что логично конечно. Все пакеты в штатном режиме будут идти через R1. R2 никакой деятельности по маршрутизации пакетов вести не будет, пока доступен Master.

    Теперь протестируем это, на тестовой машине с адресом 192.168.100.10 шлюз по умолчанию стоит 192.168.100.3
    Подключение по локальной сети - Ethernet адаптер:

    DNS-суффикс этого подключения . . :
    IP-адрес . . . . . . . . . . . . : 192.168.100.10
    Маска подсети . . . . . . . . . . : 255.255.255.0
    Основной шлюз . . . . . . . . . . : 192.168.100.3

    Начинаем пинговать и потом гасим основной роутер R1

    C:\Documents and Settings\Администратор>ping -t 192.168.100.3

    Обмен пакетами с 192.168.100.3 по с 32 байт данных:

    Ответ от 192.168.100.3: число байт=32 время=1мс TTL=64
    Ответ от 192.168.100.3: число байт=32 время=1мс TTL=64
    Ответ от 192.168.100.3: число байт=32 время<1мс TTL=64
    Ответ от 192.168.100.3: число байт=32 время<1мс TTL=64
    Ответ от 192.168.100.3: число байт=32 время<1мс TTL=64
    Ответ от 192.168.100.3: число байт=32 время<1мс TTL=64

    Еще пара атрибутов настройки VRRP-интерфейса
    interval- интервал опроса роутерами друг друга принадлежащим одному VRID, по умолчанию 1 сек.
    password-пароль для атуентификации роутеров между собой. Т.к. VRRP уязвим в плане безопасности, можно ввести пароль.
    Для этого ставим к примеру simple- атуентификацию и вписываем пароль на всех роутерах. Те роутеры где не будет пароля. либо не тот участвовать в создании виртуального роутера не будут.
    В качестве полезности: VRRP не работает через VLAN, что конечно огорчает. Однако сам VLAN можно уместить вовнутрь VRRP 😉

     

    Автор: admin, 25 июня 2013
    Рубрики: OS MikroTik Router
    Метки: , ,
    2 комментария к сообщению: “Настройка VRRP на Mikrotik”
    1. Юрий:

      Объясните пожалуйста подробнее , КАК засунуть влан внутрь ВРРП

    2. Dedicated servers:

      Его задачей является контроль работоспособности маршрутизатора в целом и наличие связи с локальной сетью. VRRP на Mikrotik позволяет использовать маршрутизаторы в режимах балансировки нагрузки или отказоустойчивости.

    Написать комментарий

    Последние статьи