Где купить Huawei P8 Lite.
  • Быстрый переход
  • Рубрики
  • Свежие записи
  • Метки
  • Архивы
  • Реклама 1
  • Реклама 2
  • Рейтинг@Mail.ru

    Добро пожаловать! Ваш IP-адрес: ec2-54-198-108-19.compute-1.amazonaws.com

    Cisco Catalyst в режиме роутера. Configuring SDM Templates

    Свитчи производства Cisco всем хороши, работают стабильно, обеспечивают работу узла на 100 %. Вот дорогие – это да.
    Помимо работы как свичт, модели 35XX, 37XX могут выступать как маршрутизаторы. При этом, если в конце стоит буковка E, имеется ввиду к примеру модель WS-C3560E-24TD-E, то у нее IPS IOS с поддержкой BGP. Модель же WS-C3560E-24TD-S содержит базовый IOS(IPB) и в нем нет BGP.

    На тему поддержки BGP – сильно обольщаться не стоит, Full-View в свитч не влезет, но для паритетов или для точек обмена пойдет на ура. Пойдет на ура потому, что производительность приведенной выше модели 65.5 Mpps. Это перекрывает все мыслимые необходимости. Такая высокая производительность связана с тем, что все операции по роутингу берет на себя свитч матрица, реализуя работу аналогичную CEF.
    Помимо настройки BGP, для работы свитча, как роутера нужно оптимизировать его в работу роутером. Для этого служат sdm templates. sdm templates отвечают за распределение памяти свитча в соответствии с задачами, которые он должен выполнять.
    Если он должен быть роутером, переводим темплейт в режим роутера:
    conf t
    sdm prefer routing
    Ctrl-Z
    wr me
    reload

    Подробнее...

    Изменение пароля пользователя root в MySQL

    Как можно изменить пароль пользователя root в MySQL под Linux, FreeBSD, OpenBSD и UNIX подобных операционных системах с использованием ssh/telnet сессии?

    Настройка пароля в MySQL является одной из основных задач и первоочередных задач. По умолчанию пользователь root является администратором в MySQL. Стоит обратить внимание, что пароль пользователя root в Linux/UNIX и root в MySQL – это разные пользователи и пароли у них также должны быть разные. Они являются самостоятельными и ничего общего между ними нет и не должно быть. Иногда можно произвести удаление пользователя root в MySQL и установить пользователя admin в MySQL в качестве администратора по некоторых соображениям, которые связаны напрямую с безопасностью.

    Подробнее...

    Как отправить администратору смс о неработающем Mikrotik Routerboard

    Разбираем созданный скрипт:

    #!/usr/bin/python
    # -*- coding: utf-8 -*-

    Импортируем необходимые модули:

    import smtplib
    from email.mime.text import MIMEText
    from email.mime.multipart import MIMEBase
    from email.mime.multipart import MIMEMultipart
    from email.header import Header
    import email
    import mimetypes
    import os

    Создаем функцию для отправки писем. Имя функции - mail, и она будет принимать значение переменной mail_text (текст письма):

    def mail(mail_text):
    mail_from = 'it-admin@gmail.com' # отправитель
    mail_to = '380684545342@sms.beeline.ua' # Получатель
    mail_subj = 'No WORK!' # заголовок письма
    mail_coding = 'windows-1251

    Параметры SMTP-сервера:

    smtp_server = "smtp.gmail.com"
    smtp_port = 587
    smtp_user = "it-admin@gmail.com" # пользователь smtp
    smtp_pwd = "pass" # пароль smtp

    Формирование сообщения:

    multi_msg = MIMEMultipart()
    multi_msg['From'] = Header(mail_from, mail_coding)
    multi_msg['To'] = Header(mail_to, mail_coding)
    multi_msg['Subject'] = Header(mail_subj, mail_coding)

    msg = MIMEText(mail_text.encode('cp1251'), 'plain', mail_coding)
    msg.set_charset(mail_coding)
    multi_msg.attach(msg)

    Отправка:

    smtp = smtplib.SMTP(smtp_server, smtp_port)
    smtp.ehlo()
    smtp.starttls()
    smtp.ehlo()
    smtp.login(smtp_user, smtp_pwd)
    smtp.sendmail(mail_from, mail_to, multi_msg.as_string())
    smtp.quit()

    Подробнее...

    Установка Redmine на FreeBSD (из портов), с БД PostgreSQL

    Установка из портов не простая, а очень простая:

    $ cd /usr/ports/redmine
    # make install clean

    При вопросе как «ставить порт?» я выбираю PostgreSQL и веб-сервер Thin (шустрый рубирельсовый веб-сервер, завязанный на EventMachine).

    Далее — настраиваем БД:

    # psql -U pgsql postgres
    # CREATE ROLE redmine LOGIN ENCRYPTED PASSWORD 'my_password' NOINHERIT VALID UNTIL 'infinity';
    # CREATE DATABASE redmine WITH ENCODING='UTF8' OWNER=redmine;

    Ещё далее — готовим редмайн к старту:

    # cd /usr/local/www/redmine/config
    # cp database.yml.example database.yml

    Подробнее...

    Русификация консоли FreeBSD UTF-8

    1. Добавляем в конфиг ядра строки:

    options TEKEN_UTF8
    options TEKEN_XTERM

    2. правим /etc/login.conf:

    russian|Russian Users Accounts:\
    :charset=UTF-8:\
    :lang=ru_RU.UTF-8:\
    :tc=default:

    Создаём хэш для login.conf:

    # cap_mkdb /etc/login.conf

    3. правим /etc/csh.cshrc - устанавливаем переменные окружения:

    setenv LANG ru_RU.UTF-8
    setenv LC_CTYPE ru_RU.UTF-8
    setenv LC_COLLATE POSIX
    setenv LC_ALL ru_RU.UTF-8

    4. аналогично для bash-подобных шеллов правим /etc/profile:

    LANG="ru_RU.UTF-8"; export LANG
    LC_CTYPE="ru_RU.UTF-8"; export LC_CTYPE
    LC_COLLATE="POSIX"; export LC_COLLATE
    LC_ALL="ru_RU.UTF-8"; export LC_ALL

    5. root должен быть англоязычным - правим /root/.cshrc:

    setenv LANG C
    setenv LC_CTYPE C
    setenv LC_COLLATE POSIX
    setenv LC_ALL C

    6. Меняем драйвер консоли 'cons25' на 'xterm' в /etc/ttys
    7. ставим порт /usr/ports/converters/convmw и с его помощью конвертируем имена файлов в UTF-8 (если было что-то названо по-русски в koi8-r):

    # convmw -f koi8-r -t utf-8 /file/path/* --notest -r

    Как защитить микротик от сканирования портов?

    В iptables есть правило
    -A INPUT -i eth1 -p tcp -m tcp --tcp-flags FIN,SYN,ACK SYN -j REJECT --reject-with icmp-port-unreachable
    (eth1 - интерфейс с ip в интернет)
    Я пробовал вкл и вкл его. И с внешнего ip сканером портов проверял на открытые порты комп с IPtables.
    При вкл правиле ни одного открытого порта на компе не обнаруживалось.

    Как подобное правило реализовать в микротик?

    Код
    /ip firewall filter
    add chain=input in-interface=eth1 protocol=tcp tcp-flags=syn action=reject reject-with=icmp-network-unreachable
    add chain=input in-interface=eth1 protocol=tcp tcp-flags=fin,syn,ack action=reject reject-with=icmp-network-unreachable

    но если включен Connection Tracking, то проще - так:

    Код
    /ip firewall filter add chain=input in-interface=eth1 connection-state=new action=reject reject-with=icmp-network-unreachable

    Защита Mikrotik от брутфорса

    Если вы хотите заблокировать доступ после 10-и не правильных попыток в минуту:

    код для /ip firewall filter

    add chain=input protocol=tcp dst-port=21 src-address-list=ftp_blacklist action=drop \
    comment="drop ftp brute forcers"

    add chain=output action=accept protocol=tcp content="530 Login incorrect" dst-limit=1/1m,9,dst-address/1m

    add chain=output action=add-dst-to-address-list protocol=tcp content="530 Login incorrect" \
    address-list=ftp_blacklist address-list-timeout=3h

    Это предотвратит SSH брутфорс на 10 дней после повторяющихся попыток. Измените блокировку по времени в случае необходимости.
    код для /ip firewall filter:

    add chain=input protocol=tcp dst-port=22 src-address-list=ssh_blacklist action=drop \
    comment="drop ssh brute forcers" disabled=no

    add chain=input protocol=tcp dst-port=22 connection-state=new \
    src-address-list=ssh_stage3 action=add-src-to-address-list address-list=ssh_blacklist \
    address-list-timeout=10d comment="" disabled=no

    add chain=input protocol=tcp dst-port=22 connection-state=new \
    src-address-list=ssh_stage2 action=add-src-to-address-list address-list=ssh_stage3 \
    address-list-timeout=1m comment="" disabled=no

    add chain=input protocol=tcp dst-port=22 connection-state=new src-address-list=ssh_stage1 \
    action=add-src-to-address-list address-list=ssh_stage2 address-list-timeout=1m comment="" disabled=no

    add chain=input protocol=tcp dst-port=22 connection-state=new action=add-src-to-address-list \
    address-list=ssh_stage1 address-list-timeout=1m comment="" disabled=no

    Перемещение системных папок и изменение их путей

    Перенос системных папок лучше сделать сразу после установки Windows, до установки программ и драйверов, т.к. при установке драйверов и в особенности программ будут создаваться каталоги и ярлыки в эти самые системные папки. Если Вы используете для хранения файлов системные папки, то перенос системных папок пользователя на не системный диск, поможет Вам сохранить свои файлы. В случае сбоя Windows, при её переустановке заданные по умолчанию системные папки будут затерты полностью, со всеми находящимися в них файлами. Но если Вы зададите свои пути к системным папкам, то всё их содержимое останется целым.

    Раньше в предыдущих версиях Windows, чтобы переместить какую-либо системную папку или изменить её путь, Вам надо было править нужное Вам значение в одной из следующих веток реестра:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

    Компания Microsoft понимая, что многие пользователи могут захотеть переместить свои системные папки, упростила пользователям эту задачу, избавив их от надобности редактировать реестр. Для перемещения системных папок и изменения их путей проделайте следующее:

    Подробнее...

    Удаление символов ^M с помощью sed

    Все время забываю синтаксис sed для удаления символов переноса строк ^M формата DOS, которые можно встретить в текстовых файлах после редактированиях в windows редакторах.

    Они меня почему-то ужасно раздражают и я вечно стремлюсь от них избавиться. Поэтому решил кинуть в блог небольшую памятку, чтобы была всегда под рукой.

    Символы переноса строк ^M, которые следует удалить, можно получить в консоли набрав комбинацию на клавиатуре:  сначала control + V и следом за этим control + M

    Вот так выглядят переносы ^M в текстовом редакторе mcedit:


    Синтаксис sed для удаления ^M следующий
    sed 's/'"$(printf '\015')"'$//g' имя_файла

    Также можно еще так:

    find . -type f | xargs -n1 sed -i » -e ‘s/^M$//’

    или так

    find . -type f | xargs -n1 sed -i -e ‘s/^M$//’

    тогда создадутся копии исходных файлов с -е в конце имени ^M в bash можно набрать нажав CTRL+V+M

    Ну и самый простой вариант это установка с портов пакета:

    /usr/ports/converters/dosunix

    Автор admin, 5 июня 2011 | OS FreeBSD, Новости | 1 коммент.
    Метки: , , , , , , ,

    Увеличение скорости работы USB-мыши, с помощью повышения опросов USB-порта

    Вы любите играть в игры, где важна быстрота реакции, но Ваша USB-мышь не относится к классу игровых мышек - просто увеличьте частоту опросов USB мыши. Например: игровая мышь Logitech G7 имеет частоту опроса равную 530 MHz, а обычная 125 MHz.

    Для установки необходимы права локального администратора:
    1) Скачайте архив MouseRate.zip и распакуйте его в папку.
    2) Откройте папку Direct Input Mouse Rate и в ней запустите программу dimr.exe
    3) Подвигайте максимально быстро курсором Вашей мыши по экрану.
    4) Запомните значение из графы Peak - это максимальная величина опросов Вашей мышки.
    5) Откройте папку HIDUSBF
    6) Нажмите правой кнопкой мыши на файл HIDUSBF.INF и выберите пункт Установить.
    7) Запустите файл setup.exe Найдите там свою мышку (она там подсвечена синим цветом) и внизу окна поставьте галочку на "Filter On Device" и поставьте там свой rate, который вам нужен.
    8 ) Нажмите на "Restart" и снова откройте dimr.exe. Если у вас до сих пор там стоит Ваше старое значение, то перезагрузите компьютер еще раз.

    Подробнее...

    Где купить Huawei P8 Lite.


    Cisco Systems
    OS FreeBSD
    OS Linux
    OS MikroTik Router