• Быстрый переход
  • Рубрики
  • Свежие записи
  • Метки
  • Архивы
  • Реклама 1
  • Реклама 2
  • Рейтинг@Mail.ru

    Добро пожаловать! Ваш IP-адрес: ec2-23-20-166-68.compute-1.amazonaws.com

    Cisco

    Восстановление IOS на Cisco Catalyst 2960

    Добрый День! Не давно возникла необходимость восстановить IOS на Cisco Catalyst 2960. По обычной методике, с помощью tftp загрузить IOS не получалось, по этому пришлось заливать по консольному кабелю.

    Порядок действий:

    • Заранее находим IOS (копируем с другого каталиста).
    • Подключаемся через консольный кабель.
    • Запускаем HyperTerminal (kitty не умеет в нужном формате передавать файлы).
    • Появляется надпись: switch:
    • Дальше надо изменить скорость порта, со стандартной 9600 на что то побольше, иначе очень при очень долго будет передаваться, для этого пишем:
      switch: set BAUD 115200
    • После смены скорости придется переподключить HyperTerminal с новой скоростью, иначе нормально работать с консолью будет невозможно.
    • Теперь на каталисте включаем копирование файла с xmodem:
      switch: copy xmodem: flash:
    • В меню HyperTerminal выбираем передачу файла (через xmodem) и указываем на файлик.
    • Ждем пока закачается IOS (мин 20ть). Затем меняем скорость консоли на обычную 9600.
    • Перезапускаем каталист.

    Настройка DHCP сервера на CISCO

    В данной статье рассматривается настройка Cisco роутера в качестве DHCP сервера. Полное описание команд DHCP сервера на Cisco Вы сможете найти на сайте производителя.

    Контрольный список конфигурации:

    1) Настройка агента DCHP базы данных или отключение "конфликтных" DHCP логов. (Обязательно)
    2) Исключение ip адресов (Обязательно).
    3) Настройка адресного пула DHCP (Обязательно).
    4) Ручное присвоение адресов (Опционально).
    5) Настройка загрузочного файла для DHCP сервера (Опционально).
    6) Настройка числа пакетов ping (Опционально).
    7) Настройка тайм аутов для пакетов ping (Опционально).
    8) Включение функциональной возможности Cisco IOS DHCP Server(Опционально).

    Подробнее...

    Как собирать логи на устройстве Cisco Systems

    В заметки описано как активировать сбор системных сообщений на оборудовании Cisco и как их потом прочитать.

    >en
    Password:

    config term
    (config)# logging on
    (config)# logging buffered 32000
    (config)# logging buffered informational

    или

    (config)#logging buffered debugging

    чтобы собирать все что только можно.

    В данном примере мы активируем логирование и размещаем информацию в кэш буфера самого устройства Cisco, уровень на котором должен работать лог – информационный.

    Чтобы посмотреть информацию которую собрала Cisco :

    #sh log

    Как видите там указано время когда это произошло.

    Произведем точную настройку времени если это необходимо -

    #clock set 10:38:00 July 2 2011

    или пользуемся NTP серверами типа pool.ntp.org

     

    Автор admin, 16 декабря 2011 | Cisco Systems | 0 коммент.
    Метки: ,

    Cisco Catalyst в режиме роутера. Configuring SDM Templates

    Свитчи производства Cisco всем хороши, работают стабильно, обеспечивают работу узла на 100 %. Вот дорогие – это да.
    Помимо работы как свичт, модели 35XX, 37XX могут выступать как маршрутизаторы. При этом, если в конце стоит буковка E, имеется ввиду к примеру модель WS-C3560E-24TD-E, то у нее IPS IOS с поддержкой BGP. Модель же WS-C3560E-24TD-S содержит базовый IOS(IPB) и в нем нет BGP.

    На тему поддержки BGP – сильно обольщаться не стоит, Full-View в свитч не влезет, но для паритетов или для точек обмена пойдет на ура. Пойдет на ура потому, что производительность приведенной выше модели 65.5 Mpps. Это перекрывает все мыслимые необходимости. Такая высокая производительность связана с тем, что все операции по роутингу берет на себя свитч матрица, реализуя работу аналогичную CEF.
    Помимо настройки BGP, для работы свитча, как роутера нужно оптимизировать его в работу роутером. Для этого служат sdm templates. sdm templates отвечают за распределение памяти свитча в соответствии с задачами, которые он должен выполнять.
    Если он должен быть роутером, переводим темплейт в режим роутера:
    conf t
    sdm prefer routing
    Ctrl-Z
    wr me
    reload

    Подробнее...

    Настройка NAT на Router Cisco

    f0/0 – внутренний интерфейс, серая сеть
    f1/0 – внешний интерфейс, ip ISP

    Необходимо выпустить машины из локальной сети в интернет.

    router#config t
    router(config)#int f0/0
    router(config-if)#ip nat inside
    router(config-if)#int f1/0
    router(config-if)#ip nat outside
    router(config-if)#exit
    router(config)#access-list 10 permit 10.100.100.0 0.0.0.255
    router(config)#ip nat inside source list 10 interface f1/0 overload
    router(config)#end
    router#wr

    Настройка мультикаста на роутере Cisco 6509

    Vlan 951 server_multicast_vlan
    Vlan 950 users_vlan

    Настройка роутера:

    SW-254(config)#ip multicast-routing # включаем функцию мультикаст-роутинга

    SW-254(config)#interface Vlan951
    SW-254(config-if)#desс M-source
    SW-254(config-if)#ip address 10.42.51.254 255.255.255.0
    SW-254(config-if)#no ip redirects
    SW-254(config-if)#ip pim sparse-mode
    SW-254(config-if)#no ip mroute-cache
    SW-254(config-if)#ip igmp join-group 239.251.1.1
    # не обязательно, в зависимости от настроек

    SW-254(config)#interface Vlan 950
    SW-254(config-if)#desc M-destination
    SW-254(config-if)#ip address 10.42.50.254 255.255.255.0
    SW-254(config-if)#no ip redirects
    SW-254(config-if)#ip pim sparse-mode

    SW-254(config)#ip pim rp-address 10.42.51.254 iptv override

    Автор admin, 27 апреля 2011 | Cisco Systems | 0 коммент.
    Метки: ,

    Настройка VTP на коммутаторах Cisco

    Настройка VTP версии 2

    Имя VTP-домена (от 1 до 32 символов):

    sw(config)# vtp domain

    Настройка пароля, который будет использоваться для аутентификации в VTP-домене (от 1 до 32 символов):

    sw(config)# vtp password

    Настройка второй версии протокола VTP:

    sw(config)# vtp v2-mode

    Настройка режима VTP:

    sw(config)# vtp mode

    Настройка VTP версии 3

    Версия 3 VTP доступна:

    * на 2960 с 12.2(52)SE
    * на 3560 с 12.2(55)SE
    * на 3750 с 12.2(52)SE

    Подробнее...

    CDP – Cisco Discovery Protocol во FreeBSD

    Не давно в интернете нашел прикольную статейку и решил ее выложить!
    CDP – Cisco Discovery Protocol, предназначен этот протокол для упрощения поиска устройств в сети, автоматической отрисовки топологии сети, этот протокол в обязательном порядке поддерживается устройствами Cisco, получить информацию на устройстве можно так:

    show cdp neighbors

    Вывод имеет такой вид:

    Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone Device 
    ID Local Intrfce Holdtme Capability Platform Port 
    ID Traversa Gig 1/0/11 137 S I WS-C3560- Gig 0/1 
    sw-core-3k56e Gig 1/0/3 130 H i386 bge0 
    sw-kyiv-2960 Gig 1/0/5 166 S I WS-C2960- Gig 0/2

    Тут отображены все устройства которые передают информацию о себе по протоколу cdp, и как можно увидеть – предоставляется информация о наименовании устройства, интерфейс куда оно включено, сколько времени прошло с последней посылки информации, тип устройства, платформа и идентификатор порта на удаленном устройстве.
    Как можно увидеть it-admin.org – это сервер под управлением FreeBSD в котором я включил поддержку с помощью порта cdpd.
    Установка его проста, в настройке он не нуждается:

    cd /usr/ports/net-mgmt/cdpd/ make install clean

    Подробнее...

    Logging — Cisco

    Логи – одна из самых замечательных и полезных функций. Благодаря логам мы можем отследить, когда возникла неисправность и какое событие ее вызвало.

    По умолчанию ведение логов, в оборудовании Cisco включено, но если это не так, то его можно включить из режима глобальной конфигурации командой logging on. При помощи logging buffered 256000 зададим объем пространства, где будут храниться сообщения. В случае если объем превысит 256 килобайт новые сообщения будут замещать старые.

    При желании, для сбора и хранения логов можно использовать внешний сервер, подключенный к сети. Для этого необходимо указать его IP адрес командой logging 192.168.1.50, где 192.168.1.50 - адрес сервера, а также включить функцию отправки с генерированных сообщений на сервер командой logging trap. В том случае, если в сети имеется несколько устройств, которые отсылают логи на сервер, для удобства слежения за полученными сообщениями, на каждом устройстве можно ввести команду login origin-id hostname, благодаря которой, каждое устройство будет указывать свое имя (имя задается командой host MySuperName, где MySuperName - имя устройства) перед сообщением. В качестве бесплатного приложения для сбора логов, можно использовать программу Kiwi Syslog Server.

    Если вы зашли на устройство через консоль, то отображение логов в процессе работы не заставит вас долго ждать. Но что делать, если вы подключились к устройству удаленно? Как правило, в данной ситуации вы не увидите ни единого сообщения о том, что происходит на устройстве в данный момент. Для того чтобы этого избежать, в режиме глобальной конфигурации достаточно прописать terminal monitor и logging monitor.

    Подробнее...

    Добавления пользователя в Cisco IOS с определенными привелегиями

    Пример использование привилегий для пользователей с правами: доступа в конфигурационный режим, доступ в режим интерфейса, создание ip адреса на интерфейсе, просмотра интерфейсов и просмотра конфигурации роутера:

    (config)#enable secret level level password - указывает пароль для для уровня привилегий.
    (config)#privilege interface level 2 ip address
    (config)#privilege interface level 2 ip
    (config)#privilege configure level 2 interface
    (config)#privilege exec level 2 configure terminal
    (config)#privilege exec level 2 configure
    (config)#privilege exec level 2 show interfaces
    (config)#privilege exec level 2 show running-config
    (config)#privilege exec level 2 show
    (config)#enable secret level 2 ciscopriv2


    Даже если пользователь просмотрит конфигурацию, то ему будет не доступен весь файл конфигурации, а только разрешенные.
    Также если мы создадим другой уровень привилегий, то в нем нельзя будет использовать команды описанные в уровне 2, т.е. новый уровень стянет на себя эту команду, а на 2 уровне она пропадет из списка.