• Быстрый переход
  • Рубрики
  • Свежие записи
  • Метки
  • Архивы
  • Реклама 1
  • Реклама 2
  • Рейтинг@Mail.ru

    Добро пожаловать! Ваш IP-адрес: ec2-54-226-172-30.compute-1.amazonaws.com

    Vlan

    Создания и управления VLAN во FreeBSD

    Для создания и управления VLAN во FreeBSD не используются какие-то специальные программы. Всё делается с помощью программы ifconfig.

    Первый вариант:

    Создать интерфейс vlan4:

    # ifconfig vlan4 create

    Указать, что созданный интерфейс соответствует трафику, тегированному VLAN 4 и приходящему через физический интерфейс fxp0:

    # ifconfig vlan4 vlan 4 vlandev fxp0

    Теперь можно работать с vlan4 как с обычным интерфейсом. Этому интерфейсу нужно назначить адрес. Машина будет видна в VLAN 4 по этому адресу:

    # ifconfig vlan4 192.168.16.14/24

    Предыдущие команды можно было бы совместить в одну.

    Просмотреть информацию об интерфейсе:

    # ifconfig vlan4

    vlan4: flags=8843 <UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500

    inet 192.168.16.14 netmask 0xffffff00 broadcast 192.168.16.15
    inet6 fe80::204:79ff:fe67:9671%vlan4 prefixlen 64 scopeid 0x6
    ether 00:07:e9:45:0d:2c
    media: Ethernet autoselect (100baseTX )
    status: active
    vlan: 4 parent interface: fxp0

    Видно, что в описании интерфейса появилась строка:

    vlan: 4 parent interface: fxp0

    которая говорит о том, что интерфейс vlan4 соответствует VLANу 4 на родительском сетевом интерфейсе fxp0.

    Для того чтобы интерфейсы поднимались автоматически при старте, нужно добавить в /etc/rc.conf:

    cloned_interfaces="vlan3 vlan4"
    ifconfig_vlan3="inet 192.168.15.14 netmask 255.255.255.0 vlan 3 vlandev fxp0"
    ifconfig_vlan4="inet 192.168.16.14 netmask 255.255.255.0 vlan 4 vlandev fxp0"

    Подробнее...

    Настройка маршрутизации между vlan Cisco Catalyst-3560

    Задача: настроить маршрутизацию между сетями разных VLAN.

    Настройка Cisco Catalyst-3560 (L3 switch):

    1)Зададим IP – адрес коммутатору:

    Switch(config)#interface vlan 1
    Switch(config-if)#ip address 192.168.1.1 255.255.255.0
    Switch(config-if)# no shutdown

    2)Создадим vlan-ы:

    Switch(config)#vlan 2
    Switch(config-vlan)#name net2
    Switch(config)#vlan 3
    Switch(config-vlan)#name net3

    3)Создадим vlan – интерфейсы:

    Switch(config)#interface vlan 2
    Switch(config-if)#ip address 192.168.2.1 255.255.255.0
    Switch(config)#interface vlan 3
    Switch(config-if)#ip address 192.168.3.1 255.255.255.0

    4)Назначим trunk порты (подключение коммутатор-коммутатор):

    Switch(config)#finterface fastEthernet 0/1
    Switch(config-if)#switchport trunk encapsulation dot1q

    Подробнее...

    Описание протокола — VLAN Trunking Protocol (VTP)

    VLAN Trunking Protocol (VTP) — проприетарный протокол компании Cisco Systems, предназначенный для создания, удаления и переименования VLANов на сетевых устройствах. Передавать информацию о том, какой порт находится в каком VLANе, он не может.

    Описание протокола: Версии протокола

    Версия 3 VTP доступна:

    * на 2960 с 12.2(52)SE
    * на 3560 с 12.2(55)SE
    * на 3750 с 12.2(52)SE

    Сообщения VTP

    * Summary advertisements
    * Subset advertisements
    * Advertisement requests
    * VTP Join messages (используются для pruning)

    Режимы работы протокола

    На коммутаторе VTP может работать в трёх режимах:

    * Server (режим по умолчанию):
    Можно создавать, изменять и удалять VLAN из командной строки коммутатора,
    Генерирует объявления VTP и передает объявления от других коммутаторов,
    Может обновлять свою базу данных VLAN при получении информации от других VTP-серверов в домене,
    Сохраняет информацию о настройках VLAN в файле vlan.dat во flash,
    * Client:
    Нельзя создавать, изменять и удалять VLAN из командной строки коммутатора,
    Передает объявления от других коммутаторов,
    Синхронизирует свою базу данных VLAN при получении информации VTP,
    Сохраняет информацию о настройках VLAN только в RAM. Если коммутатор был выключен, то информация о VLAN теряется и должна быть обновлена с помощью обновления от сервера или клиента,
    * Transparent:
    Можно создавать, изменять и удалять VLAN из командной строки коммутатора, но только для локального коммутатора,
    Не генерирует объявления VTP,
    Передает объявления от других коммутаторов,
    Не обновляет свою базу данных VLAN при получении информации по VTP,
    Сохраняет информацию о настройках VLAN в NVRAM,
    Всегда использует configuration revision number 0.

    Подробнее...

    MAC ACL на Cisco Catalyst

    MAC ACL, также известный как Ethernet ACL предназначен для фильтрации non-IP трафика на VLAN или физических интерфейсах Layer 2 используя MAC адреса в именованном расширенном MAC extended ACL.
    Шаги по конфигурации MAC ACL подобны обычным именованным расширенным ACL. MAC ACL могут применяться только для фильтрации входящего трафика. Для определения MAC Extended ACL используется команда mac access-list extended. После того, как MAC ACL будет создан, его необходимо наложить на интерфейс Layer 2 используя команду mac access-group [acl-name] in.
    В примере ниже  показано, как создать и применить MAC ACL для блокировки определенного MAC адреса, пропуская остальной трафик.

    Switch#
    Switch(config)#mac access-list extended ban_mac
    Switch(config-ext-macl)#deny host 0015.1729.890a any
    Switch(config-ext-macl)#permit any any
    Switch(config-ext-macl)# exit
    Switch(config-if)#interface gigabit 0/15
    Switch(config-if)#mac access-group ban_mac in
    Switch(config-if)#end
    Switch#

    Автор admin, 23 апреля 2010 | Cisco Systems, Новости | 1 коммент.
    Метки: , , , , ,

    Q-in-Q настройка в Cisco Catalyst 3750

    Q-in-Q, так же это называют dot1q tunneling, это система двойного тегирования вланов. То есть, допустим у нас есть канал на некую тех площадку, на которой подключены клиенты, клиенты должны быть изолированы друг от друга с помощью vlan, но транспорт не позволяет обеспечить нужное количество вланов на каждого клиента, а владельцы транспорта дают один влан и как говорится крутись как хочешь. Вот для таких случаев замечательно подходит dot1q туннелирование, когда внутрь одного влана на входе упаковываются вланы, а на выходе транспорта распаковываются. Остается добавить, что не все виды коммутаторов поддерживают Q-in-Q, среди коммутаторов Cisco поддерживают Q-in-Q 35хх, 37xx, 45xx. Среди продуктов D-Link поддерживает Des-3825, тут Q-in-Q называется Double Vlan. И все коммутаторы производства ExtremeNetworks, они называют эту технологию vMan.

    Схема коммутации для создания Q-in-Q будет выглядеть так:

    Подробнее...

    Настраиваем Trunk между свичами Cisco Catalyst и FreeBSD

    И так перед нами стоит задача настроить и соединить два свича и Server на FreeBSD , используя trunk порты, для того, что бы пользователи подключенные к Cisco Catalyst видели IP-адреса FreeBSD и Cisco Catalyst свичи находились во vlan`е управления. Для этого у нас есть два свича Cisco Catalyst 3560G к которым подключены два сегмента сети в разных vlan.
    Подробнее...

    Автор admin, 23 февраля 2010 | Cisco Systems, Новости | 0 коммент.
    Метки: , , , ,

    Первоначальные настройки на Cisco Catalyst 3560G

    И так, для того чтобы нам настроить минимальные настройки на Cisco Catalyst 3560G , необходимо знать , что на любых Cisco по дефолту не имеются ни какие настройки
    т.е. он пуст!!!
    Для того чтобы на начать настраивать понадобиться к свичу подключиться
    в Windows можно использовать Hiper Terminal для подключения к com порту
    Подробнее...

    Автор admin, 24 января 2010 | Cisco Systems, Новости | 0 коммент.
    Метки: , ,